Service Disruption
Resolved
Nov 14 at 05:04am CST
Over a 2.5 hour timespan early today, there was a disruption of service. Here is what happened.
There were elevated requests from some bad sites which unexpectedly caused a ripple effect at the platform with one of our processes. This then affected some sites with some web hosts, causing them to at times load slower or timeout due to a bug in a recent release of the plugin. We have since patched the issue on the platform, so this can never happen again, and are working on updating the plugin on the highest priority.
We take uptime very seriously. We have multiple redundancies for everything. We have devops coverage 24/7. We have monitoring systems in place for everything. Since our public launch 2.5 years ago, we have never had a situation like this occur.
Our team did a full retrospective today on the situation. We take these things very seriously. If there is anything additional we can do, please let us know.
Affected services
SureCart Platform
Created
Nov 14 at 04:02am CST
We are still investigating this issue and seeing sporadic increases and decreases in response time. We've traced this back to a high level of requests from some bad sites which is causing a ripple effect at the platform with one of our processes.
Affected services
SureCart Platform