Back to overview
Downtime
Requests Timing Out
Nov 14 at 03:30am CST
Affected services
SureCart Platform
Resolved
Nov 14 at 04:00am CST
Request times have been improved, but we are still investiging degraded performance.
Affected services
SureCart Platform
Created
Nov 14 at 03:30am CST
We are experiencing requests timing out across the platform due to elevated throughput and performance issues with a downstream service. We are diagnosing the issue and working on a fix.
Affected services
SureCart Platform